Username: Password: Remember me
Search + Advanced
Package Details

docker 17.05.0-1
https://www.docker.com/
Pack, ship and run any application as a lightweight container

Category: daemons

Submitter: Guillaume
Maintainer: Skool182
Votes: 11

License: Apache

Last Updated: 2017/06/13 - 14:46:16 +0000
First Submitted: 2014/05/11 - 13:54:57 +0000

Tarball :: PKGBUILD

Dependenciesbridge-utils device-mapper glibc iproute2 lib32-systemd libseccomp sqlite3 

Required by docker-compose

Sources

Comment by: Skool182 on Mon, 02 Jan 2017 11:03:26 +0000


 Hi, I'm trying to update to 1.12.5, but I cant build anymore the source code because of an unknown btrfs error.
I try to use the official binaries, but when I start the service, I got an aufs error…

This is a known error, when updating the kernel.
https://github.com/docker/docker/issues/14026

In my case, I removed the aufs dir on the /var/lib/docker directory, and docker is working again.

Comment by: ChakraHeaven on Mon, 02 Jan 2017 09:58:20 +0000


After last Chakra update cycle (kernel 4.8.6-1) dockerd can not be started bei systemd.

I tested with success latest docker binary release (1.12.5).
Could you please update to this version. Thanks.

Comment by: Skool182 on Tue, 23 Aug 2016 08:07:30 +0000


There is an issue with the 1.12.1 release that needs  libseccomp 2.2.1. But in core, it's the 2.2.0 release.

I will check for the best way to resolve that problem.

Comment by: Skool182 on Tue, 24 May 2016 16:37:42 +0000


Thanks, I will upload the 1.11.1 tonight (the PKGBUILD is on my other computer)

Comment by: deogracia on Mon, 23 May 2016 14:26:43 +0000


Hi Skool182 big_smile

Thanks! I disowned it so you can own it and try ^^

I'm ... a bit late :p

You can ask me if you need someone else to test.

Comment by: Skool182 on Sat, 21 May 2016 17:33:10 +0000


I've builded the package from the Archlinux PKGBUILD, and it seems to work. We need to add 3 new packages as dependancies in CCR but it's not too hard.

I can try if you want.

Comment by: deogracia on Wed, 27 Apr 2016 08:51:47 +0000


Thanks @s8321414 

I'll give it a try.

Comment by: s8321414 on Wed, 27 Apr 2016 06:51:03 +0000


@deogracla I have disowned it, if you want to maintain it, welcome to take it.
It's too hard to maintain now...

Comment by: deogracia on Tue, 26 Apr 2016 15:25:32 +0000


won't build

uRL: http://chakraos.org/ccr/packages/do/doc … ker.tar.gz
Edit docker PKGBUILD with $EDITOR? [Y/n] 

Edit docker.install with $EDITOR? [Y/n] 

==> Création du paquet docker 1.10.3-1 (mar. avril 26 17:22:26 CEST 2016)
==> Vérification des dépendances pour l’exécution...
==> Vérification des dépendances pour la compilation...
==> Récupération des sources...
  -> Clonage du dépôt docker git...
Clonage dans le dépôt nu '/tmp/ccrbuild-1000/docker/docker/docker'
remote: Counting objects: 212669, done.
remote: Compressing objects: 100% (285/285), done.
remote: Total 212669 (delta 163), reused 12 (delta 12), pack-reused 212370
Réception d'objets: 100% (212669/212669), 124.27 MiB | 4.85 MiB/s, fait.
Résolution des deltas: 100% (139803/139803), fait.
Vérification de la connectivité... fait.
==> Validation des fichiers sources avec md5sums...
    docker ... Ignoré
==> Extraction des sources...
  -> Création d’une copie de travail du dépot docker git...
Clonage dans 'docker'...
fait.
Basculement sur la nouvelle branche 'makepkg'
==> Lancement de build()...
# WARNING! I don't seem to be running in the Docker container.
# The result of this command might be an incorrect build, and will not be
#   officially supported.
#
# Try this instead: make all
#

---> Making bundle: dynbinary (in bundles/1.10.3/dynbinary)
Created binary: bundles/1.10.3/dynbinary/dockerinit-1.10.3
Building: bundles/1.10.3/dynbinary/docker-1.10.3
# github.com/docker/docker/daemon/graphdriver/btrfs
.gopath/src/github.com/docker/docker/daemon/graphdriver/btrfs/btrfs.go:164: args.name undefined (type C.struct_btrfs_ioctl_vol_args_v2 has no field or method name)
==> ERREUR : Une erreur s’est produite dans build().
    Abandon...
The build failed.

Comment by: hsantanna on Fri, 16 Oct 2015 14:06:06 +0000


can't install, got this error message:

"---> Making bundle: dynbinary (in bundles/1.8.2/dynbinary)
Created binary: bundles/1.8.2/dynbinary/dockerinit-1.8.2
Building: bundles/1.8.2/dynbinary/docker-1.8.2
# github.com/docker/docker/pkg/devicemapper
.gopath/src/github.com/docker/docker/pkg/devicemapper/devmapper_wrapper.go:191: Cdeps.device undefined (type *C.struct_dm_deps has no field or method device)
==> ERROR: A failure occurred in build().
    Aborting...
The build failed."